Page 1 of 1

DU 4.1.2: 100% CPU usage...

Posted: Thu Apr 06, 2006 12:26 pm
by Hanjo
Hi,

I have a serious problem since updating DU 4.0.5 to 4.1.2; since then the engine is a) not working any more, but b) consuming all my capacity:
Image
It's not possible to end the service or kill the process DUEngine.exe (even with admin priviliges), just a restart kills it.
I already tried to delete all my configuration in the registry, but - as you can see - it didn't help at all...

thx
Hanjo

Posted: Sat Apr 08, 2006 1:58 am
by miki
I had a similar problem with version 4.1.0
but it's solved with 4.1.2

In my PC was the SAME problem with CPU (impossible to kill or close)
the PC restart was the only solution.
This problem occurs only when the service try to update the IP address;
you can do a test: disable all "DNS accounts" and try if there is again the problem
then enable the "Debug" Logs and start the "DNS accounts"
if the CPU goes to 100%, post the logs here or ask support via email.

Regards

Miki

Posted: Tue Apr 11, 2006 1:00 pm
by willynt
Hi Guys,

It seems that we have a serious issue somewhere...
Miki hasd this poroblem with the 4.1.0, but it's gone int he 4.1.2
Now Hanjo has it in 4.1.2... Very weird.

Is it %100 reproducible ?
Or is it working sometimes ?

Did you try the miki sugegstion ?

Waiting for yiour feedbacks
William

Posted: Thu Apr 13, 2006 3:09 pm
by Hanjo
Hi,

thanks for responding:

Ok, the problem is the IP Detection, it is a) not working and b) causing the high CPU usage

Unfortunatelly, I'm not able to post any debug information, because the service does not give any information. You just see the egg timer left to the IP Detection, but it's not succeeding nor is it failing. It's just remaining forever in this state (I can disable, but it's not changing until system restart).

I will try once more with disabled IP Detection during startup...

Posted: Mon Apr 17, 2006 11:59 pm
by miki
Hi Hanjo, it's important disable the automatic DNS update and enable the Debug logs.
It's important to have the debug log when the CPU goes to 100% and
see the exact point it appen

Miki

Posted: Mon May 01, 2006 2:39 am
by ttoews
I'm getting this exact same problem. The only way I was able to get around this was to either uninstall the software or change the service to manually start and then reboot my system.

I just upgraded to the latest version when this started happening. I decided to post my work arounds for this problem above should someone else have the same problem.

I will attempt to get some debug logs and post them.

Posted: Mon May 01, 2006 2:46 am
by ttoews
It looks like it lost my settings. Fortunately I did a backup on my old version. But from what I can see there is no way to set the logging option without having the directengine running. And of course as soon as it's running it becomes totally unresponsive.

So, at first glance, it would appear that there is no way I can do anything but install the older version.

I'd better have the older version on my system somewhere because I can't see anywhere on the website to download the older version. And you should always be able to download older versions of software just in case this happens.

Posted: Mon May 01, 2006 3:04 am
by ttoews
Yup, I had the older version and it's now working just fine. I'll try the next version I guess after 4.1.2. Maybe this problem will be fixed then. And maybe not.

You can't even get into the settings to change the debug So I guess I'd have to change the debug settings while running the old software, install the new software, uninstall the new software and install the old software. Along with varous reboots along the way.

Posted: Thu May 04, 2006 12:52 pm
by willynt
Hi guys,

Here is a way to add the "debug" option for log feature without usi├žng the admin interface:
- Stop the engine
- Launch regedit to HKEY_LOCAL_MACHINE\SOFTWARE\Fraggers.net\DirectUpdate\Engine
- Edit the "LogMask" DWORD value and make sure it contains the 6th bit ON. It means that in hexa notation, the 2nd digit (from right to left) contains 1.
Usually, change default value (0x100f) to 0x101f.
- then, restart the engine.

I already tracked the bug, and it's effectivly when an IP detection thread starts... But can't figure out why till now :(

Waiting for any information that could help...
Thx a lot
William

Posted: Mon May 22, 2006 9:24 pm
by ttoews
I do see several interesting error messages in the System Event log -

"Dependent Assembly Microsoft.VC80.MFCLOC could not be found and Last Error was The referenced assembly is not installed on your system."

"Resolve Partial Assembly failed for Microsoft.VC80.MFCLOC. Reference error message: The referenced assembly is not installed on your system."

"Generate Activation Context failed for C:\Program Files\DirectUpdate\MFC80.DLL. Reference error message: The operation completed successfully." Note that the Event log flags that message with a red error despite the contents of the message.

And now the DirectUpdate admin module is locked up and won't display any data.

Yet another reboot.
.

Posted: Mon May 22, 2006 9:48 pm
by ttoews
I've emailed the contents of my debug log off to willynt. I can live with it not updating my DNS for now as it does send me an email when the IP address changes. It's just rather irritating obviously.

VC80.MCFLOC

Posted: Fri Jun 09, 2006 10:00 am
by Bunce
I get the same 3 MCFLOC errors in the system log, but I've not noticed the CPU problem. I think they may be different issues.

Posted: Mon Jun 12, 2006 8:48 am
by willynt
MFCLoc errors in the eventviewer has been fixed.
But it's not related to the "100% cpu" issue...

I will release the new 4.5.0 soon.

William

Posted: Sun Jun 18, 2006 8:41 pm
by miki
We'll wait :D

Let we know when there is a beta available, so we can help you to test it :wink:

Regards

Miki

Posted: Sat Sep 09, 2006 8:01 pm
by miki
After weeks of test and debug is available the version 4.5.1
with new features and bug fix

Version 4.5.1 is now available!

Miki