Error when using secure protocol

Asks questions about settings, bugs...

Moderators: willynt, DiskDrive, fifinou

Guest

Error when using secure protocol

Postby Guest » Thu May 04, 2006 9:44 pm

Hi

If i select secure update (updating dyndns.org (dynamic)), i get the following error:
An account update failed.
Account name: xyz.ath.cx
Current IP address: 0.0.0.0
New IP address (detected): 84.73.222.190
Error: The token supplied to the function is invalid - 0x80090308
-----------------------------------------------
Message generated: Thu, 04 May 2006 22:29:13 by DirectUpdate (v 4.1.2)
From machine PSRV5
For info, visit http://www.directupdate.net

Any ideas

Cheers Peter

Guest

Postby Guest » Wed May 17, 2006 8:20 am

I'm experiencing the same error today. :(
At the last Tuesday when the computer was used for the last time, it worked fine w/o the error.

Guest

Postby Guest » Wed May 17, 2006 8:24 am

Anonymous wrote:I'm experiencing the same error today. :(
At the last Tuesday when the computer was used for the last time, it worked fine w/o the error.
I forgot to write my service; It's DNS Made Easy.

willynt
Site Admin
Posts: 242
Joined: Thu Mar 10, 2005 6:32 am

Postby willynt » Thu Jun 01, 2006 8:45 am

Hi Guys,

I tested with Dyndns.org (dynamic) with secured updates and it worked.
I can't test with dnsmadeeasy, cos I do not have an account.

Are you still getting the error ?

ParAvion
Posts: 1
Joined: Wed May 17, 2006 8:42 am

Postby ParAvion » Fri Jun 02, 2006 1:10 am

willynt,
Thank you for the testing. I am the one who wrote about DnsMadeEasy.

I found the problem was due to a misconfiguration on the upstream firewall/proxy which corrupted some HTTPS connections.
DU is working fine now. :)

Thanks!

mon
Posts: 9
Joined: Fri Jun 02, 2006 1:01 pm
Location: Switzerland
Contact:

Postby mon » Fri Jun 02, 2006 1:08 pm

Hi again

Hi William

Thanks for answering

Results from last test on 1.6.06:


[INF]- 01/Jun/2006 20:59:39 - Account "abc.ath.cx" updating with IP
84.73.xxx.xxx...
[ERR]- 01/Jun/2006 20:59:40 - Account "abc.ath.cx" update failed. -
Error 0x80090308:The token supplied to the function is invalid
[INF]- 01/Jun/2006 20:59:40 - Sending email DirectUpdate - abc.ath.cx
update failed...
[SCS]- 01/Jun/2006 20:59:40 - Email 'DirectUpdate - abc.ath.cx update
failed' successfully sent to <hostmaster@xxx.ch>

AND:

An account update failed.
Account name: abc.ath.cx
Current IP address: 84.73.xxx.xxx
New IP address (detected): 84.73.xxx.xxx
Error: The token supplied to the function is invalid - 0x80090308
-----------------------------------------------
Message generated: Thu, 01 Jun 2006 20:59:40 by DirectUpdate (v 4.1.2)
From machine PSRV5
For info, visit http://www.directupdate.net

Have found more informations in syslog:

Generate Activation Context failed for C:\Program Files\DirectUpdate
v4\MFC80.DLL.
Reference error message: The referenced assembly is not installed on your
system.

Resolve Partial Assembly failed for Microsoft.VC80.MFCLOC.
Reference error message: The referenced assembly is not installed on your
system.

Dependent Assembly Microsoft.VC80.MFCLOC could not be found and Last Error
was The referenced assembly is not installed on your system.

Cheers Peter

willynt
Site Admin
Posts: 242
Joined: Thu Mar 10, 2005 6:32 am

Postby willynt » Tue Jun 06, 2006 7:59 am

The issue with MFC80.DLL in event viewer/syslog has benn fixed (in the upcoming 4.5.0)
But I have absolutely no clue about your https issue...

Can you try with aother "free" dynds provider, just to be sure it comes from the dyndns.org server certificate or from directupdate...

Regards
William

mon
Posts: 9
Joined: Fri Jun 02, 2006 1:01 pm
Location: Switzerland
Contact:

Postby mon » Mon Jun 12, 2006 8:38 pm

Hi William

Same error with no-ip:

An account update failed.
Account name: pesrv1.no-ip.org
Current IP address: 84.73.222.190
New IP address (detected): 84.73.222.190
Error: The token supplied to the function is invalid - 0x80090308
-----------------------------------------------
Message generated: Mon, 12 Jun 2006 21:34:21 by DirectUpdate (v 4.1.2)
From machine PSRV5
For info, visit http://www.directupdate.net

Regards Peter

mon
Posts: 9
Joined: Fri Jun 02, 2006 1:01 pm
Location: Switzerland
Contact:

Postby mon » Mon Jun 12, 2006 8:42 pm

Hi William

Maybe important information:

for ip-check and for update, i have configured a proxy. Because of Firewall, it's not possible to go to internet directly.

Regards Peter

miki
Posts: 114
Joined: Wed Mar 23, 2005 8:46 pm
Location: Italy
Contact:

Postby miki » Sun Jun 18, 2006 8:43 pm

mon wrote:Hi William

Same error with no-ip:

An account update failed.
Account name: pesrv1.no-ip.org
Current IP address: 84.73.222.190
New IP address (detected): 84.73.222.190
Error: The token supplied to the function is invalid - 0x80090308
-----------------------------------------------
Message generated: Mon, 12 Jun 2006 21:34:21 by DirectUpdate (v 4.1.2)
From machine PSRV5
For info, visit http://www.directupdate.net

Regards Peter


Hi mon,

post here more info to be able to understand.
Try to enable the debug option in the Log config

Regards

Miki

mon
Posts: 9
Joined: Fri Jun 02, 2006 1:01 pm
Location: Switzerland
Contact:

Postby mon » Sun Jun 18, 2006 9:02 pm

[INF]- 18/Jun/2006 21:57:04 - Account "pesrv1.no-ip.org" updating with IP 80.218.244.125...
[DBG]- 18/Jun/2006 21:57:04 - Account update: DNS service acquiring...
[DBG]- 18/Jun/2006 21:57:05 - Account update: DNS service acquired
[DBG]- 18/Jun/2006 21:57:05 - Account update: updating...
[DBG]- 18/Jun/2006 21:57:05 - Account update: preparing request...
[DBG]- 18/Jun/2006 21:57:05 - Account update: preparing request done
[DBG]- 18/Jun/2006 21:57:05 - Account update: sending request...
[DBG]- 18/Jun/2006 21:57:05 - Account update: starting URLSend...
[DBG]- 18/Jun/2006 21:57:05 - Account update: In _URLSend creating URL...
[DBG]- 18/Jun/2006 21:57:05 - Account update: In _URLSend creating URL done
[DBG]- 18/Jun/2006 21:57:05 - Account update: In _URLSend sending URL...
[DBG]- 18/Jun/2006 21:57:05 - Account update: In _URLSend sending URL done
[DBG]- 18/Jun/2006 21:57:05 - Account update: URLSend done
[DBG]- 18/Jun/2006 21:57:05 - Account update: sending request done
[DBG]- 18/Jun/2006 21:57:05 - Account update: update ended
[ERR]- 18/Jun/2006 21:57:05 - Account "pesrv1.no-ip.org" update failed. - Error 0x80090308:The token supplied to the function is invalid
[DBG]- 18/Jun/2006 21:57:05 - Executing action 'Send an email'...
[INF]- 18/Jun/2006 21:57:05 - Sending email DirectUpdate - pesrv1.no-ip.org update failed...
[SCS]- 18/Jun/2006 21:57:05 - Email 'DirectUpdate - pesrv1.no-ip.org update failed' successfully sent to <hostmaster@xyz.ch>
[DBG]- 18/Jun/2006 21:57:05 - Executed action 'Send an email'. Returned code: 0x00000000

Cheers Peter

mon
Posts: 9
Joined: Fri Jun 02, 2006 1:01 pm
Location: Switzerland
Contact:

Postby mon » Sun Jun 18, 2006 9:07 pm

And the Mail for message above:

An account update failed.
Account name: pesrv1.no-ip.org
Current IP address: 80.218.244.125
New IP address (detected): 80.218.244.125
Error: The token supplied to the function is invalid - 0x80090308
-----------------------------------------------
Message generated: Sun, 18 Jun 2006 21:57:05 by DirectUpdate (v 4.1.2)
From machine PSRV5
For info, visit http://www.directupdate.net

miki
Posts: 114
Joined: Wed Mar 23, 2005 8:46 pm
Location: Italy
Contact:

Postby miki » Sun Jun 18, 2006 9:52 pm

Do you have enable update with secure protocol?
Try to disable it and check again.

Anoter user found a problem due to a misconfiguration on the upstream firewall/proxy which corrupted some HTTPS connections

Regards

Miki

mon
Posts: 9
Joined: Fri Jun 02, 2006 1:01 pm
Location: Switzerland
Contact:

Postby mon » Mon Jun 19, 2006 6:44 pm

Hi

- Without "secure update" all updates works fine
- the check off new ip-addrs goes over proxy without problems
- no problems with broser (IE and FF) to browse over https pages from DynDNS or no-ip or any other web-page in www over https (443)

Cheers Peter

miki
Posts: 114
Joined: Wed Mar 23, 2005 8:46 pm
Location: Italy
Contact:

Postby miki » Tue Jun 20, 2006 1:06 am

I don't have a reply for you ... only the workaround to get DU working.
I think willy could help you to understand if it's a DU problem or your Router/Firewall problem, but you should provide more detailed informations.

Regards

Miki


Return to “Questions, bugs,...”

Who is online

Users browsing this forum: No registered users and 5 guests